GUI Version Mismatch Error  (Read 6609 times)

Bullitt

  • Newbie
  • *
  • Posts: 4
  • Country: us
GUI Version Mismatch Error
« on: March 15, 2023, 12:55 »
Hey guys,
I'm getting this error that's preventing me to join (but I can join other servers):
"Failed launching URL Package 'GUI' version mismatch"
Now, I've had this game since it came out and have run across just about every error/fix with this game. I may have come across this before but can't remember.
Here's where I'm at:
Googled the error and only something similar came up which prompted me to do the following...
I cleared the cache. Didn't work
I replaced the system folder with a virgin copy. (I keep one on hand for troubleshooting) Also didn't work.
I deleted the game and redownloaded from Steam. Still can't get on.
My PC is fairly new with Windows 11.
Did you guys make a change to the server settings?

Bullitt

  • Newbie
  • *
  • Posts: 4
  • Country: us
Re: GUI Version Mismatch Error
« Reply #1 on: March 15, 2023, 14:36 »
I found out that when you uninstall through steam it doesn't get rid of settings or previous downloaded stuff. Just reinstalls the game parts. Deleted the game off my computer and started from scratch. I'm good now.

Piglet

  • 1337
  • *
  • Posts: 3181
  • Country: gb
Re: GUI Version Mismatch Error
« Reply #2 on: March 15, 2023, 16:53 »
You shouldn't get this kind of error unless you installed gui.u into your system directory (or just leave ut2004 running and have not restarted over a time the package on the server changed)

The general advice is to let the cache manager deal with packages. Don't install anything into your system directory.

If you get this, delete gui.u from system and restart.

I'm not sure what steam can have been doing to get you into this problem.

Grim_Fandango

  • Sr. Member
  • *
  • Posts: 100
  • Country: scotland
Re: GUI Version Mismatch Error
« Reply #3 on: March 16, 2023, 20:32 »
Hope you don't mind me jumping in.

Regarding playing over Steam (or similar) and a good old fashioned CD install.
If both were fully patched and up to date...are there be any drawbacks or benefits of playing one over the other?

I've always pondered this but kept forgetting to ask.  :)
• Men are from Mars, Women are from Venus, made up genders are from Uranus.
• It's all shits & giggles until someone giggles and shits.
• I wish I had the aim of an Eastern Bloc player.

Piglet

  • 1337
  • *
  • Posts: 3181
  • Country: gb
Re: GUI Version Mismatch Error
« Reply #4 on: March 16, 2023, 21:07 »
No. No difference, though you're more in control in a stand-alone install.

Grim_Fandango

  • Sr. Member
  • *
  • Posts: 100
  • Country: scotland
Re: GUI Version Mismatch Error
« Reply #5 on: March 16, 2023, 21:31 »
Hadn't thought of that, thanks!
• Men are from Mars, Women are from Venus, made up genders are from Uranus.
• It's all shits & giggles until someone giggles and shits.
• I wish I had the aim of an Eastern Bloc player.

Piglet

  • 1337
  • *
  • Posts: 3181
  • Country: gb
Re: GUI Version Mismatch Error
« Reply #6 on: March 17, 2023, 09:09 »
@Grim_Fandango ... thank you! That will really help.

Grim_Fandango

  • Sr. Member
  • *
  • Posts: 100
  • Country: scotland
Re: GUI Version Mismatch Error
« Reply #7 on: March 17, 2023, 13:51 »
Happy to chip in, it'd be rude not to :)
• Men are from Mars, Women are from Venus, made up genders are from Uranus.
• It's all shits & giggles until someone giggles and shits.
• I wish I had the aim of an Eastern Bloc player.

Piglet

  • 1337
  • *
  • Posts: 3181
  • Country: gb
Re: GUI Version Mismatch Error
« Reply #8 on: March 17, 2023, 14:36 »
You'd be amazed how few do!

holyspam

  • 1337
  • *
  • Posts: 329
  • Country: gr
Re: GUI Version Mismatch Error
« Reply #9 on: March 18, 2023, 12:24 »
Hope you don't mind me jumping in.

Regarding playing over Steam (or similar) and a good old fashioned CD install.
If both were fully patched and up to date...are there be any drawbacks or benefits of playing one over the other?

I've always pondered this but kept forgetting to ask.  :)
Steam might inject some crap on UT, like overlays etc...and this is an old game so it can create lags.

Gil-galad

  • Full Member 
  • *
  • Posts: 71
  • Country: pt
  • Hail the Holy Flying Spaguetti Monster!
Re: GUI Version Mismatch Error
« Reply #10 on: March 18, 2023, 14:47 »
In Linux, Steam overlay can make the game crash. I just disabled it entirely.
Using Steam+Luxtorpeda has given me better handling of peripherals in-game, but in Windows I suppose you wouldn't have those issues since manufacturers usually provide a Windows driver for their hardware.
« Last Edit: March 18, 2023, 17:40 by Gil-galad »
His sword was long, his lance was keen.
His shining helm afar was seen;
the countless stars of heaven's field
were mirrored in his silver shield.

The Fall of Gil-galad - J. R. R. Tolkien